aboutsummaryrefslogtreecommitdiffstats
path: root/dev/MinGfx/tests/gui_plus_opengl/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Strapp <matt@mattstrapp.net>2021-09-20 18:15:14 -0500
committerMatt Strapp <matt@mattstrapp.net>2021-09-20 18:15:14 -0500
commit342403a02f8063903d0f38327430721d4d0ae331 (patch)
tree29d020a27bc16939c568dd4b29166566d1c0e658 /dev/MinGfx/tests/gui_plus_opengl/CMakeLists.txt
parentFix parenthesis (diff)
downloadcsci4611-342403a02f8063903d0f38327430721d4d0ae331.tar
csci4611-342403a02f8063903d0f38327430721d4d0ae331.tar.gz
csci4611-342403a02f8063903d0f38327430721d4d0ae331.tar.bz2
csci4611-342403a02f8063903d0f38327430721d4d0ae331.tar.lz
csci4611-342403a02f8063903d0f38327430721d4d0ae331.tar.xz
csci4611-342403a02f8063903d0f38327430721d4d0ae331.tar.zst
csci4611-342403a02f8063903d0f38327430721d4d0ae331.zip
Diffstat (limited to 'dev/MinGfx/tests/gui_plus_opengl/CMakeLists.txt')
-rw-r--r--dev/MinGfx/tests/gui_plus_opengl/CMakeLists.txt88
1 files changed, 44 insertions, 44 deletions
diff --git a/dev/MinGfx/tests/gui_plus_opengl/CMakeLists.txt b/dev/MinGfx/tests/gui_plus_opengl/CMakeLists.txt
index 5e49e7c..b54ddaa 100644
--- a/dev/MinGfx/tests/gui_plus_opengl/CMakeLists.txt
+++ b/dev/MinGfx/tests/gui_plus_opengl/CMakeLists.txt
@@ -1,44 +1,44 @@
-# This file is part of the MinGfx cmake build system.
-# See the main MinGfx/CMakeLists.txt file for details.
-
-project(mingfx-test-gui-plus-opengl)
-
-
-# Source:
-set (SOURCEFILES
- gui_plus_opengl.cc
- main.cc
-)
-set (HEADERFILES
- gui_plus_opengl.h
-)
-set (CONFIGFILES
-)
-
-
-# Define the target
-add_executable(${PROJECT_NAME} ${HEADERFILES} ${SOURCEFILES})
-
-
-# Add dependency on libMinGfx:
-target_include_directories(${PROJECT_NAME} PUBLIC ../../src)
-target_link_libraries(${PROJECT_NAME} PUBLIC MinGfx)
-
-# Add external dependency on NanoGUI
-include(AutoBuildNanoGUI)
-AutoBuild_use_package_NanoGUI(${PROJECT_NAME} PUBLIC)
-
-
-
-# Installation:
-install(TARGETS ${PROJECT_NAME}
- RUNTIME DESTINATION ${INSTALL_BIN_DEST}
- COMPONENT Tests)
-
-
-# For better organization when using an IDE with folder structures:
-set_property(TARGET ${PROJECT_NAME} PROPERTY FOLDER "Tests")
-source_group("Header Files" FILES ${HEADERFILES})
-set_source_files_properties(${CONFIGFILES} PROPERTIES HEADER_FILE_ONLY TRUE)
-source_group("Config Files" FILES ${CONFIGFILES})
-
+# This file is part of the MinGfx cmake build system.
+# See the main MinGfx/CMakeLists.txt file for details.
+
+project(mingfx-test-gui-plus-opengl)
+
+
+# Source:
+set (SOURCEFILES
+ gui_plus_opengl.cc
+ main.cc
+)
+set (HEADERFILES
+ gui_plus_opengl.h
+)
+set (CONFIGFILES
+)
+
+
+# Define the target
+add_executable(${PROJECT_NAME} ${HEADERFILES} ${SOURCEFILES})
+
+
+# Add dependency on libMinGfx:
+target_include_directories(${PROJECT_NAME} PUBLIC ../../src)
+target_link_libraries(${PROJECT_NAME} PUBLIC MinGfx)
+
+# Add external dependency on NanoGUI
+include(AutoBuildNanoGUI)
+AutoBuild_use_package_NanoGUI(${PROJECT_NAME} PUBLIC)
+
+
+
+# Installation:
+install(TARGETS ${PROJECT_NAME}
+ RUNTIME DESTINATION ${INSTALL_BIN_DEST}
+ COMPONENT Tests)
+
+
+# For better organization when using an IDE with folder structures:
+set_property(TARGET ${PROJECT_NAME} PROPERTY FOLDER "Tests")
+source_group("Header Files" FILES ${HEADERFILES})
+set_source_files_properties(${CONFIGFILES} PROPERTIES HEADER_FILE_ONLY TRUE)
+source_group("Config Files" FILES ${CONFIGFILES})
+